Thursday, January 24, 2013

Boot images not updated after upgrading to ConfigMgr 2012 SP1

This week I had another nice issue in ConfigMgr 2012 SP1. The Boot images were not migrated from WinPE 3.0 (which is Windows 7) to WinPE 4.0 (which is Windows 8). Also Upgrade Distribution Points was generating an error. This because Boot images on WinPE 3.0 are not supported anymore.
 
 
Looking on MS TechNet I found the following post: Boot images not updated after upgrading to SP1 in System Center 2012 Configuration Manager
Another issue has something to do with McAfee Access Protection on the ConfigMgr server. McAfee is blocking the creation of the boot image package: Only finalized boot images are supported 
 
For me this did the trick: 
  • Rename the boot.wim and the default boot wims in each architecture folder of the <smsinstall>OSD\boot\ folder – both the i386 and x64 to <wim>.bak
  • Starting with the i386 folder first...Find the install folder of the ADK, which should be here if you installed with the defaults: “C:\Program Files (x86)\Windows Kits\8.0\Assessment and Deployment Kit\Windows Preinstallation Environment\x86\en-us\winpe.wim”. You will need to copy the winpe.wim to the <smsinstall>OSD\boot\i386 folder. Rename it to boot.wim.
  • You will also need to copy it again, but this time rename it so it matches the name of the default boot wim for the site – so it should look like boot.<packageid>.wim
  • Update default boot image. Click “Execute Method” -> input object path as SMS_BootImagePackage.PackageID="<Image ID you see in the Console e.g. POL00001>" -> UpdateDefaultImage
  • You will need to do this for the x64 folder as well. Do not do this for any custom boot images – this is just to update the default boot wims installed during setup of the site.

After that open properties of both Boot images in ConfigMgr and choose Reload on the Images tab. The OS version 6.2.9200.16384 should be displayed instead of OS version 6.1.7600.16385 now.

After that remove McAfee Access Protection (when installed) to update both Boot images on the ConfigMgr server. The Update Distribution Points Wizard should complete succesfully now.
You will be fine after that!

1 comment:

  1. Nice. Thanks for blogging this.

    ReplyDelete