Friday, May 31, 2013

Enterprise Mobility Management Smackdown whitepaper available now!

This whitepaper is the 4th in the Smackdown series and is focused on Enterprise Mobility Management solutions.

A blog with link to the whitepaper is available HERE.

Do you want to know the real difference between “Mobile Device Management” and “Mobile Application Management”? Do you want to know the role of Enterprise Mobility in BYO and Consumerization of IT? Are you looking for insights into Enterprise Mobility in Application and Desktop Delivery? Are you looking for an independent overview of the Enterprise Mobility Management (EMM) solutions and curious about the different features- and functions each EMM vendor is offering? If so, the EMM Smackdown whitepaper is a MUST read!

Thursday, May 30, 2013

Using KMS Client Setup Keys during deployment

Last month I did a new ConfigMgr 2012 SP1 installation. When deploying the Windows 7 image, which was created by ConfigMgr Capture media, no activation by KMS (Key Management Service) was done. This because MAK (Multiple Activation Key) was used in the image during installation. When deploying the same image afterwards, no KMS activation can be done anymore. There is a solution however; just use the applicable KMS client setup keys below.

KMS Client Setup Keys
Operating System Edition
Product Key
Windows 7
Windows 7 Professional
Windows 7 Professional N
Windows 7 Enterprise
Windows 7 Enterprise N
Windows 7 Enterprise E
Windows Server 2008 R2
Windows Server 2008 R2 HPC Edition
Windows Server 2008 R2 Datacenter
Windows Server 2008 R2 Enterprise
Windows Server 2008 R2 for Itanium-Based Systems
Windows Server 2008 R2 Standard
Windows Web Server 2008 R2

After using above keys in the Apply Windows Settings step in your task sequence, MAK registration is replaced with KMS. Then activation can be done by the KMS host again. It's still needed however to buy a KMS host key for doing the actual activation, but it will work this way!
When seeing this, activation can be done!

For more information about KMS read this blogpost
For more KMS Client Setup Keys read this thread

Wednesday, May 29, 2013

Jalasoft Xian SNMP Simulator has been released!

Sponsor post
Download the new Xian SNMP Device Simulator v4 now!

The new Jalasoft Xian SNMP Device Simulator is available for download now! Just go to the website below and download it for free. Some of the features are: 
  • Simulate, routers, switches and other SNMP devices
  • Robust background running service
  • Easy to use console
  • Support for SNMP v1, v2 and v3
This simulator is great if you want to test any network monitoring tool, if you need to set up a demo or a create a POC environment. Of course you can use it to test Jalasoft's network monitoring solution Xian Network Manager also!

Veeam Backup and Replication v7 with Built-In WAN Acceleration

Sponsor post

Veeam announces two disruptive features, that we’ve kept in a secret: Built-in WAN Acceleration and Backup from Storage Snapshots.

Built-in WAN Acceleration NEW
Get backups offsite 50x faster
Remove the hurdles to offsite storage with automated, agent-free backup copy jobs and built-in WAN acceleration.
Backup from Storage Snapshots NEW
Dramatically Improve RPOs
Make backups and replicas as often as every 5 minutes – even during business hours – with no impact on the production environment and running VMs.

Sound exciting? Learn more!

Tuesday, May 28, 2013

Doing a Group Policy update during OS deployment

Last month I did a new ConfigMgr 2012 SP1 installation. For installing a specific application it was needed to do a Group Policy update first. Case is this isn't actually allowed during OS deployment. When doing a "GPupdate /force" during a task sequence the system will be hanging on that specific step, and stops deploying. Microsoft has the following to mention on this topic:

The Setup Windows and ConfigMgr task sequence action is responsible for running Group Policy on the newly installed computer. The time at which Group Policy is applied during the task sequence action depends on the operating system being deployed. For Windows XP and Windows Server 2003, Group Policy is applied after the Setup Windows and ConfigMgr task sequence action is completed. On Windows Vista and Windows Server 2008, Group Policy is applied after the task sequence is finished.

When using Windows 7 or Windows 8, Group Policy is applied after the task sequence is finished also. A workaround which can be used is to add a mandatory deployment for an application, which will be active after deployment. That way the application will be installed after deployment, when Group Policy is already active.

Just remember: adding an extra last step in a task sequence for a computer restart (or multiple restarts) doesn't resolve this issue. A computer restart is needed after the task sequence deployment to make Group Policy active on the system. Hope it helps!

Monday, May 27, 2013

BSOD in VMware 4.1 when booting with WinPE 4.0 images

Last month I did a new ConfigMgr 2012 SP1 installation. When using ConfigMgr boot or capture images on VMware 4.1 a blue screen of death (BSOD) was showed. Because I created the boot images manually, I wasn't sure if it was the WinPE 4.0 boot images or VMware. It turned out it was VMware 4.1 after all. Just use the solution below to make it all functional again.

Shutdown the VM first and copy this BIOS file in it:

Then edit the VMware configuration (vmx) file and add the following lines in here:
bios440.filename = "bios.440.rom"
mce.enable = "TRUE"
cpuid.hypervisor.v0 = "FALSE"
vmGenCounter.enable = "FALSE"

That's all needed. WinPE 4.0 (which is Windows 8) will work in a older VMware environment from now on also!

Thanks to Roel Janssens (@roeljanssens) for helping me out!

Thursday, May 23, 2013

No ConfigMgr boot images created during installation

Last month I did a new ConfigMgr 2012 SP1 installation. During installation there were no boot images (based on WinPE 4.0) created. This because McAfee VirusScan was active during the installation & configuration. I saw that before doing another installation when upgrading from ConfigMgr 2012 to SP1. That post can be found here: Boot images not updated after upgrading to ConfigMgr 2012 SP1. This time no boot images were created at all.

Let's have a look how to create them manually. The steps are different then before, so a new blogpost is needed.
  • Rename the boot.wim and the default boot wims in each architecture folder of the <smsinstall>OSD\boot\ folder – both the i386 and x64 to <wim>.bak
  • Starting with the i386 folder first...Find the install folder of the ADK, which should be here if you installed with the defaults: “C:\Program Files (x86)\Windows Kits\8.0\Assessment and Deployment Kit\Windows Preinstallation Environment\x86\en-us\winpe.wim”. You will need to copy the winpe.wim to the <smsinstall>OSD\boot\i386 folder. Rename it to boot.wim.
  • Import the boot images in ConfigMgr with the following lines: Name: Boot image (x86), Version: 6.2.9200.16384, Image path: \\<SCCM server>\<SCCM Site code>\OSD\Boot\i386\boot.wim and for the second one: Name: Boot image (x64), Version: 6.2.9200.16384, Image path: \\<SCCM server>\<SCCM Site code>\OSD\Boot\x64\boot.wim
  • Don't forget to check "Deploy this boot image from the PXE-enabled distribution point" and press Apply. After that a new boot image is created in the <smsinstall>OSD\boot\ folder, with the PackageID in the name. This will be copied to the RemoteInstall folder (WDS) also.

Just do an "Distribute Content" to add them both to the Distribution point, and boot images are there again!

Friday, May 17, 2013

Internet Explorer 10 Compatibility View

Something different then Microsoft System Center now. When starting Internet Explorer on Windows client or Windows server it's possible that web-portals and/or web-applications doesn't seem to work. I see that in my own work and sometimes at customer locations also. The solution for this is to start a Compatibility View. Not everyone seems to know how to start one, so therefore this short blogpost.

Just press F12 in any web-window to start a nice little bar with a lot of functionality. Within this bar the Browser Mode can be changed to Internet Explorer 7, 8, 9 and 10. In both my own work and at customer locations this did the trick to start web-portals and/or web-applications again. No need to use a different browser from now on. Hope it helps and have a nice weekend!

Monday, May 13, 2013

My Samsung ATIV S review, a lot of phone for your money

Last month I received my new mobile phone for the next 2 years. After using Android for the last years, both 2.x and 4.x versions, it was time for something different. Because I'm using iOS already on my iPad, my choice was fallen on Windows Phone 8. This also because colleagues who are using Windows Phone 7 are still happy after using the device for over 2 years! When looking for a high-end Windows Phone 8 device you have the choice between Nokia, HTC and Samsung. For me it was Nokia Lumia 920 or Samsung ATIV S to choose from. After many sleepless nights (LOL) I decided to order the ATIV S. This because of the larger display, better battery and less weight. For me it was the better choice. Let's start the review!

Samsung announced their Windows Phone first last year, but released it last at all. This probably because Samsung wants to sell Android (Galaxy) phones as much as possible, and Windows Phone is just a second choice. Nokia on the order hand are selling Windows Phone devices as much as possible. When you go for good support or multiple device choices, Nokia is the better choice here. For me I was looking for something new, looking at price and specifications, Samsung is the better choice. ATIV S can be ordered for over 100 euros less than Lumia 920. ATIV S has a larger 4.8 inch Super AMOLED display, a 2300mAh battery and is just 135 grams in weight. Last but not least ATIV S has a replaceable battery and SD-card. ATIV S has a physical start button (to unlock the device and go to the start screen) and can be used 2 days on a single battery load. Not bad I guess :)

Enclosed an comparison between HTC 8X, Lumia 920 and ATIV S:

For me Windows Phone 8 OS is a relief, I really think it's a very good OS. It' s very fast, looking good, handy in usage, live tiles are just great, supports integration with Facebook, Twitter and LinkedIn, and offers something new! There is a good search option for installed apps, much settings to configure (more then I thought actually). Bing integration is nice for a daily random wallpaper, Microsoft apps like Office, OneNote, Internet Explorer, Xbox, Skype, Lync and Skydrive are all in place. There are less apps available when using Android, but for most apps there's an alternative app available. More apps are coming every day! The persons tile shows contacts with all information available, like Mail, Facebook, Twitter and LinkedIn data. Photos and videos can be saved in the cloud (Skydrive) immediately.

I think I like my new phone more then earlier phones, just because of Windows phone OS. That's definitely a compliment to Microsoft! When Windows Blue is released later this year (look HERE for more information about it), Windows Phone will be even better I guess. Hope you like my review, and think about a Windows Phone device yourself. For questions about Windows Phone just use comments below. Samsung ATIV S: a lot of phone for your money!

Wednesday, May 8, 2013

Microsoft's Windows Blue is released later this year

Microsoft has confirmed that the successor to Windows 8 will roll out later this year. Windows 8.1 would be released in late June already as a preview during the Build conference in San Francisco!

The new version of Windows is codenamed Windows Blue, and is expected to essentially be an update (no Windows 9). Microsoft says it will let the company respond to the customer feedback since the launch of Windows 8 and RT. Among the feedback Microsoft have listened to is to (probably) bring back the Start button.

Microsoft announced that it has now sold more than 100 million Windows 8 licenses, and over 250 million Windows Store downloads. That means that after 6 months Windows 8 is now selling equal with Windows 7, which also hit the 100 million licenses mile marker in a 6 month period. And it did it on a lot of devices.

Microsoft says some 2,400 devices are now certified for Windows 8 and RT. Generally speaking this is pretty good news for Microsoft. The retail launch for Windows 8.1 is planned for August this year. The upgrade will be free for Windows 8 users. More news soon!

Source: multiple websites

Tuesday, May 7, 2013

Reporting Services - No Reports shows up in Console!

When installing Reporting Services for ConfigMgr integration, it's possible that no reports shows up in the ConfigMgr console. This because a domain user (as recommended) is used, and no additional permissions are set on that account. In this blogpost I explain how to install Reporting Services, which account permissions are needed, and how ConfigMgr integration is done.

First Reporting Services on a SQL Server (instance) is needed. This can be installed once per instance. In SCCM 2007 it could be used only in the default instance (which is named MSSQLSERVER). In ConfigMgr 2012 it can be used both on a default or named instance. During installation use a domain user (service) account. Special permissions are set after installation.

Important: Before doing ConfigMgr integration make sure reporting is working okay already. Just open "Reporting Services Configuration Manager" and click on browse at Web Service URL and Report Manager URL. The following results must be seen then:
Result on Web Service URL (1)
Result on Report Manager URL (1)

After that install the Reporting services role in ConfigMgr on the server where the Reporting Services database is installed. On other servers it's not possible to configure the role for reporting. Just use the same (service) account which was used before. Choose verify and make sure all fields are filled-in correctly. Now let's have a look if reports are showing up. Click again on both URL's:
Result on Web Service URL (2)
Result on Report Manager URL (2)

If all is okay, reports are showing up in ConfigMgr console also. When this is not the case additional permissions are needed. Most of time this is needed when Reporting Services is installed on a different server. Just click on the arrow next to ConfigMgr in the Report Manager URL and choose Security. Click "New Role Assignment". Fill in the (service) account used for Reporting Services before. Select all available roles (or less when needed). Just do the same for the domain administrator account also. Select OK and restart the "SQL Server Reporting Services" to enable it.

It will looks like this:

That's it for now. Reporting Services reports should be available in the ConfigMgr console now. They can be used from the URL also; results are the same. Subscriptions can be set on both places.

Monday, May 6, 2013

New Xian Wings Promotion

Sponsor post


Xian Wings bundle for Smart Phones 135$us
Xian Wings HD for iPad 300$us

This promotion expires by the end of may.